RFC چیست؟

 

 

متون بسيار کامل ولی خشک و ثقيل که در مورد مفاهيم مختلف شبکه بحث می‌کنند. اين فايل‌ها به

 صورت متنی و با پسوند txt هستند و به‌عنوان مرجع (برای مراجعه و نه مطالعه کامل) کاربرد دارند. اين

فايل‌ها يک‌بار منتشر شده و هرگز تغيير داده نمی‌شوند (حتی اگر حاوی اشتباه باشند.)

آر اف سی ها از سايت‌های بسياري قابل دسترس هستند ولی سايت مورد علاقه من برای RFCها، سايت زير است:

http://www.ietf.org/rfc/xxxxxxx.txt

که به‌جای xxxxxxx نام rfc موردنظر را می‌نویسيم. مثلا برای دسترسی به rfc791 بايد آدرس را به‌ صورت زير تايپ کنيم:

http://www.ietf.org/rfc/rfc791.txt



- ليست مشهورترين RFCها

+General Information
RFC1360 IAB Official Protocol Standards
RFC1340 Assigned Numbers
RFC1208 Glossary of Networking Terms
RFC1180 TCP/IP Tutorial
RFC1178 Choosing a Name for Your Computer
RFC1175 FYI on Where to Start:
A Bibliography of Inter-networking Information
RFC1173 Responsibilities of Host and Network Managers:
A Summary of the Oral Tradition of the Internet
RFC1166 Internet Numbers
RFC1127 Perspective on the Host Requirements RFCs
RFC1123 Requirements for Internet Hosts—Application and Support
RFC1122 Requirements for Internet Hosts—Communication Layers
RFC1118 Hitchhiker"s Guide to the Internet
RFC1011 Official Internet Protocol
RFC1009 Requirements for Internet Gateways
RFC980 Protocol Document Order Information

+TCP and UDP
RFC1072 TCP Extensions for Long-Delay Paths
RFC896 Congestion Control in IP/TCP Internetworks
RFC879 TCP Maximum Segment Size and Related Topics
RFC813 Window and Acknowledgment Strategy in TCP
RFC793 Transmission Control Protocol
RFC768 User Datagram Protocol

+IP and ICMP
RFC1219 On the Assignment of Subnet Numbers
RFC1112 Host Extensions for IP Multicasting
RFC1088 Standard for the Transmission of IP Datagrams over
NetBIOS Networks
RFC950 Internet Standard Subnetting Procedure
RFC932 Subnetwork Addressing Schema
RFC922 Broadcasting Internet Datagrams in the Presence of Subnets
RFC9l9 Broadcasting Internet Datagrams
RFC886 Proposed Standard for Message Header Munging
RFC815 IP Datagram Reassembly Algorithms
RFC814 Names, Addresses, Ports, and Routes
RFC792 Internet Control Message Protocol
RFC791 Internet Protocol
RFC781 Specification of the Internet Protocol (IP) Timestamp Option

+Lower Layers
RFC1236 IP to X.121 Address Mapping for DDN
RFC1220 Point-to-Point Protocol Extensions for Bridging
RFC1209 Transmission of IP Datagrams over the SMDS Service
RFC1201 Transmitting IP Traffic over ARCNET Networks
RFC1188 Proposed Standard for the Transmission of IP Datagrams
over FDDI Networks
RFC1172 Point-to-Point Protocol Initial Configuration Options
RFC1171 Point-to-Point Protocol for the Transmission of
Multiprotocol Datagrams over Point-to-Point Links
RFC1149 Standard for the Transmission of IP Datagrams on Avian
Carriers
RFC1055 Nonstandard for Transmission of IP Datagrams over
Serial Lines: SLIP
RFC1044 Internet Protocol on Network System"s HYPERchannel:
Protocol Specification
RFC1042 Standard for the Transmission of IP Datagrams over
IEEE 802 Networks
RFC1027 Using ARP to Implement Transparent Subnet Gateways
RFC903 Reverse Address Resolution Protocol
RFC895 Standard for the Transmission of IP Datagrams over
Experimental Ethernet Networks
RFC894 Standard for the Transmission of IP Datagrams over
Ethernet Networks
RFC893 Trailer Encapsulations
RFC877 Standard for the Transmission of IP Datagrams over
Public Data Networks
 
 

استفاده از برخي امكانات شبكه در لينوكس( 2 )

به دلیل عجله بیش از حد دوستان بابت دونستن فونت فارسی لینوکس تصمیم گرفتیم که در ابتدا مبحث قابل توجه دوستان را ارائه دهیم  و بعد به ادامه بحث بپردایم.

 

تنظيم مودم:

برخلاف پيكربندي كارت شبكه كه معمولا براي كارت هاي رايج بدون دردسرانجام ميشود مودم ها(خصوصا مودم هاي داخلي) در برخي موارد كاربران لينوكس را با مشكل مواجه مي سازد.

درلينوكس برنامه شماره گيري به نام KPPP وجود دارد که ضمن كمك به تنظيم مودم عمل شماره گيري را فراهم مي سازد براي اين كار پس از اجراي اين برنامه وانتخاب ISP به منظور اتصال به شبكه راه دور يا قسمت Setup به سراغ پنل Device مي رويم ونوع اتصال مودم را انتخاب مي كنيم در اين قسمت گزينه هاي مختلفي وجود دارد كه قابل انتخاب است مثلا اتصال ttys0 همان پورتي است كه كاربران ويندوزآن را بعنوان اولين پورت سريال يا Com1 مي شناسند يا ttys1 معادل Com2 است والي آخر هر کدام از اين پورت ها كه انتخاب شدند بايد به ازاي هر كدام از آن سري هم به پنل Modem زده ودگمه Qvery Modem رابزنيم تا اگر لينوكس موفق به كشف مودم در پورت مورد نظر شد پيغام Modem is ready نمايان شود.

استفاده از امكانات شبكه

يكي از اولين فوايد دسترسي به كامپيوترهاي موجود در يك شبكه استفاده از فايل هاي موجود بر روي; آنهاست برنامه XSMBROWser يا همان سامباي مشهور اين امكان را براي ما فراهم ميسازد پس از اجراي اين برنامه صفحه اي نمايان شده و از ما مي خواهد تا با انتخاب شبكه مورد نظر كار خود را انجام دهيم در اينجا ابتدا به وسيله كليك كردن بر روي دگمه +Network يک شبكه را به سامبا معرفي مي كنيم.

در اين جا يك نام اختياري براي آن انتخاب كرده و نوع ارتباط با آن شبكه را در قسمت Type مشخص مي نماييم كه مي تواند يكي از دو حالت زيرباشد:

Broadcast.1

در اين حالت كامپيوتر اضافه شده به شبكه يك آدرس IP را بعنوان دامنه يا محدوده در شبکه رها مي کند و هر كامپيوتري كه آدرسش در اين محدوده قرار گيرد به آن جواب مي دهد ودرليست كامپيوترهايي كه برخي از فايل هايشان قابل دسترسي است قرار مي گيرد مثلا اگر آدرس 192.168.110.255 را وارد كنيم كليه كامپيوترهايي كه با آدرس 192.168.110.0هستند به آنها جواب مي دهند

Wins.2

در اين حالت كامپيوترهاي موجود در شبکه از يك سرور با ويژگي; Wins استفاده مي كنند و مي توانند با رجوع به اين سرور واحد با يكديگر ارتباط برقرار كنند كافي است در اين جا آدرس IP مربوط به سرور Wins را به همراه يك نام كاربر و رمز عبور معتبر دامنه شبكه وارد نماييم سرور Wins مسوول نگهداري ليستي از كامپيوترهاي موجود در شبكه به همراه آدرس IP آنهاست و هر گاه كامپيوتري نياز به ارتباط با كامپيوترديگري داشته باشد آدرس IP آن را از سرور Wins درخواست مي كند به هر صورت پس از انتخاب يكي از دو حالت فوق ليستي از كامپيوترهاي شبكه نمايان ميشود که با كليك بر روي هر كدام مي توان به فايل هاي به اشتراك گذاشته شده آنها دسترسي پيدا كرد

فونت فارسی در لینوکس

نصب فونت فارسی روی گنوم :

قبل از نصب فونت فارسی لازم است چند فونت فارسی استاندارد که به فرمت TTF هستند در چندین شاخه از لینوکس نصب شوند ...
البته بجای آنها می توان از فونتهای متن بازی که اخیراً در پروژه فارسی سازی لينوکس تولید شده استفاده کرد :
۱- کلیه فونتهای TTF باید در دایرکتوری های زیر کپی شوند؛ لازم است بعد از کپی کردن هر یک از شاخه ها دو دستور mkfontdir و mkfontscale را به ترتیب در محیط متنی اجرا شوند :
file: /usr/lib/openoffice/share/fonts/truetype
file: /usr/X11R6/lib/X11/fonts/misc/
file: /usr/X11R6/lib/X11/fonts/TTF/
file: /usr/X11R6/lib/X11/fonts/75dpi/
file: /usr/X11R6/lib/X11/fonts/100dpi/
file: /usr/X11R6/lib/X11/fonts/util/
۲- برای تصحیح طرح بندی فارسی صفحه کلید در ردهت لینوکس ۹.۰ و فدورا دستور زیر قبل از کپی کردن فونتها اجرا شوند:
File:/usr/X11R6/lib/X11/xkb/symbols/pc/
۳- برای اضافه کردن امکان تغییر زبان کیبوردتان در گنوم می توانید دستور زیر را در کنسول لینوکس وارد کنید:
setxkbmap us+ir -option grp:shift_toggle,grp_led:scroll
بعد از وارد کردن این دستور با فشردن همزمان دو کلید shift زبان صفحه کلید تغییر می کند؛ در صورتی که نوشته ها به درستی نشان داده نشوند لازم است یک فونت فارسی انتخاب شده و با آن به هر دو زبان فارسی و انگلیسی تایپ شود سپس با کلید ctrl + A تمام متن را انتخاب کرده و فونت آن به Nazli برگردانده شود؛ از این پس می توان به راحتی در محیط گنوم لینوکس فارسی تایپ کرد.
این متن با افپن آفیس ۱.۱ در محیط گنوم نوشته شده است .

فونت فارسی آزاد

 

با سلام به دلیل احتیاج داشتن فوری دوستان به فونت فارسی لینوکس بحث قبل خود که در مورد امکانات استفاده از شبکه در لینوکس بود را به تعویق انداختم تا دوستان زودتر به جواب خود برسند .

پروژه‌ی Free Perisan Unicode Fonts سعی دارد تا مجموعه فونت‌هایی استاندارد بر اساس یونی‌کد و صد البته آزاد ایجاد نماید. این پروژه یک پروژه‌ی زیر مجموعه از پروژه‌ی اصلی FPF است. در این پروژه برانیم تا فونت‌های فارسی آزاد موجود را بررسی نماییم و در صورت داشتن مشکلاتی با استانداردهای Unicode مشکلات را برطرف نماییم. در حقیقت باید از مجوزهای آزاد مانند GNU/GPL ممنون باشیم که این فرصت را به ما می‌دهند تا بتوانیم در صورت دیدن مشکلات در برنامه‌ها بلافاصله دست بکار شویم و مشکلات را خودمان حل کنیم و پس از آن با منتشر نمودن دوباره‌ی برنامه به جامعه‌ی خودمان نیز کمک کنیم. در حال حاضر این پروژه با یک فونت منتشر شده است، سایر فونت‌ها نیز پس از بررسی و رفع عیوب در ماه‌های آینده منتشر خواهند شد.

پروژهی Free Persian Font یا «فونت فارسی آزاد» همان‌طور که از نام آن بر می‌آید پروژه‌ای است برای ایجاد فونت فارسی آزاد، به زبان دیگر این پروژه در نظر دارد تا فونتی تحت مجوز GNU/GPL که مجوزی آزاد است ایجاد نماید. با توجه به مسائل فنی و امکانات موجود تصمیم گرفته شد تا این فونت با فرمت True Type ایجاد شود و قطعا برای داشتن فونتی مناسب و استاندارد نیاز به پیروی از یک استاندارد مناسب بود. در حال حاضر یکی از کامل‌ترین و مناسب‌ترین استانداردها برای ایجاد فونت‌هایی که با زبان فارسی بدون مشکل رفتار کنند استاندارد جهانی ISO 10464 یا Unicode UCS است. بنابراین ما نیز تصمیم گرفتیم تا فونت خود را بر این اساس ایجاد کنیم.

چرا به فونت فارسی آزاد نیاز داریم؟

در حال حاضر فونت‌های فارسی بسیاری بر روی وب موجود هستند، اما اغلب همه‌ی آن‌ها دارای حق انتشار انحصاری هستند و استفاده از آن‌ها در پروژه‌های آزد ممنوع می باشد. با توجه به سرعت گسترش محلی سازی و بین‌المللی سازی در پروژه‌های اوپن سورس و آزاد ترجمه‌های فارسی مختلفی برای محیط‌های آزاد و اوپن سورس ایجاد شده‌اند، مانند ترجمه‌ی توزیع‌های SuSE و Mandriva و Fedora یا میزکارهای XFCE و GNOME و KDE. اما متاسفانه به دلیل نبود فونت فارسی آزاد و مناسب در سال‌های قبل بسیاری از این ترجمه‌های فارسی در پروژه‌ها قابل استفاده نبودند، چرا که فونتی برای نمایش ترجمه‌ها موجود نبود، به زبانی دیگر فونتی آزاد برای استفاده در این پروژه‌ها موجود نبود، با دیدن چنین شرایطی پروژه‌ی فونت فارسی آزاد با همت آقای «عباس ایزد» که خود مترجم بسیاری از توزیع‌ها و میزکارهای لینوکس است راه‌اندازی شد تا این شکاف پوشانده شود. در حال حاضر مفتخریم که یک نسخه‌ی قابل استفاده از فونت فارسی را منتشر کرده‌ایم و کاربران بسیاری آن را نصب و تست نموده‌اند.



 

استفاده از برخي امكانات شبكه در لينوكس ( 1 )

كارت شبكه:

يكي ازملزومات اتصال اوليه به يك شبكه محلي وجود كارت شبكه و تشخيص آن ازجانب لينوكس است. اين كاردر مراحل نصب لينوكس وبه صورت خودكار انجام مي شود.

پس ازورود به محيط KDE لينوكس لازم است تا قبل از هر كاري جهت استفاده از امكانات شبكه اقدام به پيكربندي كارت شبكه مورد نظر نمود.

برنامه ويژه تنظيم كارت شبكه در بعضي ازلينوكس ها مثل Knoppix از همان ابتداي بالا آمدن سيستم عامل در منوي اصلي برنامه هاي لينوكس و تحت عنوان Configure Network Card وجوددارد.

دربرخي لينوكس هاي ديگر اين برنامه به صورت پيش فرض در ليست برنامه هاي اصلي قرار ندارد بلكه بايد آن راازطريق پكيج ويژه نصب برنامه در آن لينوكس مثل پكيج Yast وقسمت Network Drive در لينوكس Suse نصب كرد.

پس از اجراي اين برنامه دواتفاق باز هم برحسب نوع لينوكس مورد استفاده ممكن است رخ دهد. كاري كه قرار است انجام شود اين است كه به تنظيمات كارت شبكه با دادن يك آدرس IP جهت ورود به شبكه اقدام شود. اين كار يا ممكن است به صورت گرفتن اطلاعات لازم از كاربر به صورت مرحله به مرحله و نهايتا جمع آوري اين اطلاعات وخواندن آن به دستور IPCNFG باشد يا اين كه يك پنل گرافيكي ويژه اين كار باز شده وشروع به درخواست آن اطلاعات نمايد. در هرصورت در هنگام تنظيم كارت شبكه كاربر بايد اطلاعات زير را براي ورود به شبكه به سيستم وارد نمايد:

Use DHCP Broadcast.1

درهرشبكه يك سرور DHCP وجود دارد. اين سرور مسئول ارايه يك آدرس به هركامپيوتري است كه به آن متصل ميشود(IP). با وجود چنبن سروري در شبكه هركامپيوتربه ازاي هر دفعه اي كه به شبكه وارد مي شود يك آدرس IP به صورت ديناميك از سرور دريافت مي کند. پس كامپيوترهاي يک شبكه هيچگاه داراي آدرس IP ثابتي نبوده واين سرور است كه مشخص مي كند چه آدرسي به چه كامپيوتري داده شود. اگرسئوال فوق را با فشردن كليد YES جواب دهيد آنگاه از شما خواسته ميشود تا آدرس IP سرور DHCP را وارد كنيد و اگر جوابتان منفي باشد آنگاه اعلام كرده ايد كه مي خواهيد يك آدرس IP ثابت براي كامپيوتر خود تعيين کنيد. بنابراين بايد به قسمت دوم سوالات پاسخ دهيد.

IP Address for rth0.2

دراين قسمت بايد يك آدرس IP براي انتصاب دايم به كامپيوترخود وارد نماييد. به عنوان مثال ازآدرس 192.168.110.50 يا شبيه آن براي اتصال به يك شبكه محلي استفاده كنيد. لازم به ذكراست كه اگرسوال اول را "بلي" جواب داده باشيد به جاي اين سوال از شما آدرس سرور DHCP پرسيده خواهد شد.

Network Mask for eth0.3

اين آدرس الگوي آدرس دهي و در واقع كلاس IP انتخاب شده براي سيستم است كه معمولا درشبكه هاي محلي به صورت 255.255.255.0 انتخاب مي شود.

Broadcast Address.4

اين آدرس دامنه آدرس هاي IP موجود در شبكه را براي ارتباط با كامپيوتر ما بيان مي كند كه بر اساس Mask وارد شده در قسمت قبل محاسبه شده و صرفا از شما يك تاييد براي آن ميگيرد. طبق مسك وارد شده در قسمت قبل اين آدرس قاعدتا به صورت 192.168.110.254 مي باشد.

Default Gateway.5

همانند سرور DHCP در هر شبكه يك كامپيوتر ميتواند نقش دروازه را بازي کند. وظيفه دروازه اين است كه وسيله ارتباط بين شبکه محلي موجود را با جهان خارج برقرار سازد اين سرورازطريق مكانيسم Routing بين شبكه محلي و كامپيوتر هاي راه دور (Remote) پلي برقرار مي سازد و امكان دسترسي آنها به يكديگر را فراهم مي كند. به هرحال به توجه به ماهيت شبكه محلي موجود و وجود چنبن سروري در سيستم مي توان اين پرسش را پاسخ داد.

Name server.6

يك استاندارد TCP/IP است كه مسئول تبديل نام كامپيوتر ها به آدرس IP مخصوص به هر كدام است بدين وسيله كامپيوتر ها مي توانند هنگام ارتباط با يكديگر به جا اين كه مجبوربه كار سختي مثل تبادل آدرس هاي نه چندان مانوس IP شوند اسامي با مسماي يكديگر را به كار ببرند. به همين دليل وجود يک مترجم يا تبديل كننده در شبكه لازم است تا هر كامپيوتري نام كامپيوتر ديگر مورد نظر خود را به او بدهد و او آدرسIP آن را برگرداند و من بعد تماس بين آن دو از طريق اين آدرس انجام مي گيرد. نكته اي که در زمينه پاسخ به اين سوالات وجود دارد اين است كه تمام سرورهاي گفته شده مي توانند مثلا در يك كامپيوتر با سيستم عامل ويندوز2000سرور خلاصه شود و جواب تمامي آدرس هاي خواسته شده فوق آدرس همان سرور مثلا 192.168.110.10 باشد. پس ازاتمام پيكربندي كارت شبكه زمان استفاده از امكانات مختلف شبكه محلي فراهم مي شود.

نصب سيستم عامل لینوکس مندریک 9.2 Mandrake linux

لینوکس مندریک را به جرات میتوان یکی از ساده
ترین و زیباترین توزیعهای لینوکس موجود در جهان نامید چراکه این توزیع هدف اصلی
خودرا بر ساده نمودن رابط گرافیکی کاربر و userfriendly نمودن هرچه بیشتر سیستم
متمرکز نموده است .

برای شروع نصب ديسك اول نصب را داخل درايو
قرار دهيد و كامپيوتر خود را بوت كنيد .


كه صفحه خوش آمد گويی لينوكس مندریک را مشاهده كرديد
میتوانید با انتخاب یکی از دوگزینه موجود و فشاردادن دکمه های enter یا f1 به مرحله
بعدی وارد شويد.

نکته : لینوکس مندریک برای کامپیوترهای pc کلاس pentium طراحی شده
وبرای نصب روی کامپیوترهای 286 یا 386 و غیره باید از نسخه خاصی که برای این نوع
سخت افزارها طراحی شده و قابل داونلود میباشد استفاده کنید .


نكته: اگر شما صفحه خوش آمد گويی را
نمی بينيد، ممكن است درايو CD-ROM شما قابل بوت نباشد. فعال كردن گزينه بوت از روی
درايو CD-ROM و يا ايجاد ديسكت های بوت ميتواند به شما برای ادامه نصب كمك كند.
برای فعال كردن گزينه بوت از روی CD-ROM به صورت مقابل عمل كنيد : كامپيوتر خود را
راه اندازی كرده و در صفحه نخستين پيامی برای ورود به صفحه نصب (setup) خواهيد ديد.
برای ورود به برنامه نصب بايوس كافی است كليدهای F1 يا F2 ويا DEL را فشار دهيد. در
گزينه های موجود به دنبال موردی با عنوان Boot Options و يا Boot From و يا چيزی
مشابه آن بگرديد. پس از آنكه آنرا پيدا كرديد، اولويت نخست آنرا روی درايو CD-ROM
تنظيم كنيد. تغييرات را ذخيره كرده و خارج شويد.


اگر نصب با موفقيت انجام شد شما
ميتوانيد گزينه های بايوس را به حالت اول برگردانيد. در صورتی كه حتی با تنظيم اين
گزينه ها امكان بوت از روی CD-ROM وجود نداشت، بايد ديسكتهای نصب را از روی فايلهای
boot.img (برای كامپيوترهای معمولی)، bootnet.img (برای نصبهای از روی شبكه) يا
pcmcia.img (برای كامپيوترهای كيفی) كه روی CD نصب قرار دارند، ايجاد نماييد.
چگونگی ايجاد اين ديسكتها شرح داده خواهد شد. پس از ايجاد ديسكتها، آنها را در
درايو قرار داده و كامپيوتر خود را بوت كرده و نصب را ادامه دهيد.


در پنجره گرافیکی اول كليد Enter را
برای ورود به نصب گرافيكی، فشار دهيد. در صورتی كه كامپيوتر شما اجازه نصب بصورت
گرافيكی (رنگ بيتی و وضوح 800 در 600 پيكسل) را نمی دهد، با فشار دکمه F1 به قسمت "انتخاب
انواع ديگر نصب" مراجعه نماييد.


انتخاب انواع ديگر
نصب:


در بيشتر كامپيوتر ها شما ميتوانيد
به راحتی نصب را بصورت گرافيكی انجام دهيد. برخی مواقع مخصوصا در سیستمهای قدیمی
كارت گرافيكی شما ممكن است اين حالت را قبول نكند. همچنين با اينكه هنگام نصب سخت
افزار كامپيوتر شما شناسايی ميشود،ممكن است برخی مواقع ديسك سخت، كارت شبكه و يا
يكی از سخت افزارهای حياتی ديگر شناسايی نشده و به اطلاعات مخصوصی هنگام بوت نياز
داشته باشد.


در اينجا ليستی از انواع گزينه هايی
كه شما ميتوانيد نصب لينوكس ردهت را بوسيله آن شروع كنيد وجود دارد. پيشنهاد ميشود
در صورتی از اين گزينه ها استفاده كنيد كه گزينه گرافيكی دچار اشكال شود (مانند
هنگامی كه صفحه از گاربيج پر شده و يا سخت افزار شناسايی نمی شود).


شما ميتوانيد با تايپ linux text
جلوی اعلان نصب بصورت متنی را آغاز نماييد. از اين گزينه هنگامی استفاده نماييد كه
به نظر ميرسد برنامه نصب نتوانسته كارت گرافيك شما را شناسايی نمايد. با اين نوع
نصب رابط کاربر برنامه نصب بصورت متنی است .


نکته : قبل از آغاز نصب لازم است
کلیه سخت افزارهای شما به سیستم متصل و روشن باشند مثلا پرینتر و اسکنر و حتی
دوربین دیجیتال و ..... . این عمل باعث خواهد شد که سیستم بطور خودکار همه سخت
افزارهارا شناساپی کرده و از انجام ‍پیکربندی غیرضروری بی نیاز شوید .


در برخی شرایط نادر و در سیستمهای
قدیمیسخت افزارشما توسط سیستم شناساپی نمیشود و باید آنها را بصورت دستی معرفی
نماپید . در اینصورت باتایپ گزینه noauto به مراحل نصب در محیط غیرگرافیکی و ‍رس و
جو در مورد سخت افزارهای سیستم وارد میشوید . لازم به ذکر است که در اینصورت شما
باید یک کاربر نیمه حرفه ای لینوکس باشید تا از پس شناساپی و معرفی صحیح سخت افزار
به سیستم برآیید .


گزینه دیگر قابل استفاده در محیط
متنی vgalo که نصب را در محیط متنی بارزولوشن کم دنبال میکند . (برای کارتهای
گرافیکی فوق العاده قدیمی)


ورود به مرحله نصب
گرافیکی :


درمرحله بعد و به شرطی که شما نصب
معمولی یا گرافیکی را برگزیده باشید باید نوع زبان پیش فرض سیستم را انتخاب نمایید
. توصیه میکنم در این مرحله زبان انگلیسی را بجای زبان فارسی انتخاب وپس از پایان
نصب امکانات فارسی را اضافه کنید زیرا رابط دسکتاپ فارسی لینوکس مندریک باوجودیکه
یک انقلاب در لینوکس فارسی محسوب میشود ولی هنوز کاستی هایی مثل فونت نازیبا و
نامانوس بودن ترجمه لغات دارد و در همه محیطهای kde یا Gnome بخوبی جواب نمیدهد .


(توضیح اینکه این مشکل هیچ ربطی به
استفاده شما از زبان فارسی در برنامه های مختلف لینوکس مندریک ندارد و امکان تایپ
فارسی ‍س از نصب بسته های rpm پشتیبانی زبان فارسی در kde و نصب فونت فارسی ttf
وجود دارد )


نظر به اینکه پشتیبانی از استاندارد
یونیکد utf-8 در لینوکس مندریک بسیار توسعه یافته و در حال توسعه میباشد استفاده از
همه زبانهای زنده دنیا در این سیستم عامل بسیار تسهیل گردیده است .


نکته : شما پس از پایان نصب با
استفاده از برنامه usr/sbin/localedrake/ میتوانید زبان رابط گرافیکی فارسی یا
انگلیسی و یا هرزبان دیگری که مایل باشیر را تجربه کنید .


مرحله تاپید لیسانس
نرم افزاری :


در این مرحله شما با مستندات لینوکس
مندریک آشناشده و از قوانین و مقررات استفاده از این سیستم عامل مطلع میگردید.


مرحله انتخاب نوع
ماوس :


در این مرحله میبایست نوع و مدل
ماوس متصل به سیستم را انتخاب نمایید .


مرحله انتخاب نوع
نصب :


معمولا نوع نصب upgrade برای نصب
برروی نسخه های قبلی لینوکس مندریک خصوصا نسخه 8.1 و بعد از آن و ارتقاء به نسخه
9.2 صورت گرفته و نصب از نوع install برای نصب یک نسخه لینوکس مندریک از پایه و
ابتدا میباشد .


برای ادامه و درصورت تمایل به نصب
از نوع دوم یعنی install ادامه این مقاله شمارایاری خواهد کرد .


مرحله انتخاب سطح
امنیت سیستم security level :


انتخاب سطح امنیتی برای کسانی که
سیستمهایشان بطور دائم در شبکه با کام‍پیوترهای دیگر در ارتباط میباشد خصوصا شبکه
اینترنت و اشتراک منابع برروی شبکه اهمیت دارد . سطح امنیت پیش فرض standard تامین
کننده امنیت سیستمهای workstation و سطوح امنیتی بالاتر که نیاز به تنظیمات بیشتری
دارند برای server مناسب میباشند .


ضمنا استفاده از یک نام یا آدرس email در این مرحله بعنوان معرفی
مدیر امنیتی سیتم ضروری است چون ازاین پس کلیه پیغامهای سیستمی در مورد حریم امنیتی
لینوکس به این مدیر بصورت هشدار اعلام خواهند شد .


مرحله انتخاب محل نصب و آماده سازی
هارددیسک : Selecting the Mount Points


این مرحله از اهمیت ویژه ای برخوردار است چراکه هرگونه اشتباه
کاربر ممکن است به ازدست دادن اطلاعات موجود روی هارد دیسک وی منجر شود .


برای جلوگیری از هرگونه اشتباه به نکات زیر توجه کنید :



  • انتخاب گزینه Use free space بطور خودکارکلیه فضاهای خالی
    پارتیشن بندی نشده هارد یسک را برای استفاده لینوکس محیا میکند .
  • انتخاب گزینه Use existing partition درصورتی ممکن است که
    شماقبلا یک مرتبه لینوکس را روی سیستم خود نصب و هم اکنون در حال نصب مجدد روی
    همان پارتیشنهای ex2 یا ex3 باشید . البته شما میتوانید در طی مراحل بعدی این
    انتخاب پارتیشنهای لینوکس موجود خودرا برای استفاده مجدد فرمت نمائید.
  • انتخاب گزینه Use the free space on the Windows partition
    برای کسانی درنظرگرفته شده که قصددارند لینوکس را در کنار ویندوز به گونه ای ساده
    نصب کنند و فضاهای خالی هارددیسک را به لینوکس اختصاص دهند . البته باید دانست که
    اینکار ممکن است فضای خالی هارد دیسک را برای ویندوز محدود نماید و امکان نصب
    برنامه های دیگر برروی ویندوز باتوجه به محدودیت فضای نوجود آمده ممکن نشود .
    ضمنا این روش باوجود سادگی گاهی به ازدست دادن اطلاعات موجود روی پارتیشنهای fat
    و ntfs می انجامد و باید حتما قبلا از اطلاعات مهم پشتیبان تهیه کرد .
  • انتخاب گزینه Erase entire disk همه اطلاعات موجود روی هارد
    دیسک راپاک کرده و فضای موجود را در اختیار لینوکس میگذارد . در اینصورت شمافقط
    یک سیستم عامل و آن هم لینوکس را برروی سیستم خواهید داست و کلیه اطلاعات هارد
    دیسک شما پاک شده یا هارد دیسک جدید شما برای استفاده به روش لینوکس پارتیشن بندی
    میشود .
  • انتخاب گزینه Custom disk partitioning برای کاربران نیمه
    حرفهای توصیه میشود چون کارکردن باآن نسبتا ساده است و نیاز به تجربه کمی دارد
    ضمنا در هنگام پارتیشن بندی کاربر میتواند یکی از درایوهای خودرا انتخاب و پاک
    نموده و سپس با انجام چند مرحله از جمله انتخاب پارتیشن پاک شده و انتخاب گزینه
    auto allocate پارتیشن بندی مناسب برای لینوکس را در محل پاکسازی شده انجام دهد .
    دراین مرحله باید حداقل یک پارتیشن ریشه ( / ) با حجم 3 گیگابایت و یک پارتیشن
    swap با حجم دوبرابر مقدار ram سیستم و یک پارتیشن home با حجم دلخواه حداقل یک
    گیگا بایت برای ذخیره فایلها و داده ها و اطلاعات کاربر ایجاد کرد .

مرحله فرمت کردن
پارتیشنهای ایجادشده برای لینوکس :


در این مرحله پارتیشنهای ایجاد شده توسط کاربر با ساختار ex3 فرمت
شده و سیستم آماده ورود به مرحله بعدی مگردد.


مرحله انتخاب بسته های دلخواه برای نصب
Choose Packages to Install :


در این مرحله کاربر باید نوع بسته های دلخواه خود را با توجه به
نیازهایش و همچنین دانستن امکانات نصب بصورت server و یا workstation انتخاب نماید
. این انتخابها به تمایل کاربر و فضای خالی موجود روی پارتیشن لینوکس بستگی داشته و
هیچ محدودیتی در این زمینه مشاهده نمیشود . کاربران مبتدی باید بدانند که انتخاب
گزینه های server صرفا برای کام‍پیوترهای سرویس دهنده فایل یا پست الکترونیک یا
.... بوده و انتخابهای workstation برای کاربران خانگی یعنی client ها مناسب است و
نباید برنامه های غیر ضروری مربوط به سیستمهای سرور را که حجم و فضای هارددیسک را
اشغال میکنند بدون بررسی نیازهای موجود نصب کرد .


ضمنا ابزار های گرافیکی مفید نصب نرم افزارها مثل urpmi در محیط
مندریک لینوکس امکان نصب بعدی هر آنچه را که از قلم بیفتد در آینده فراهم می آورد و
در این مرحله هیچ مشکلی بروز نخواهد کرد .


نکته :شما برای کار در محیط های گرافیکی لینوکس حداقل باید محیط
KDE یا GNOME را نصب کنید و همانطوریکه خواهید دید محیط KDE بصورت پیش فرض انتخاب
شده و محیطی مناسب و زیبا برای کاربران فارسی زبان میباشد .


نکته 2 : درصورتی که بخواهید جزئیات دسته بندی نرم افزارها را
مشاهده و انتخاب دقیق تری روی تک تک بسته ها انجام دهید باید گزینه Choose
Individual Packages to Install را علامت بزنید .


مرحله نصب و کپی شدن فایلها :


در این مرحله مراحل کپی شده بسته های انتخاب شده شما برروی سیستم
بصورت نوار پیشرفت گرافیکی نمایش یافته و پس از اتمام کار سی دی اول بطور خودکار سی
دی های دوم و سوم از کاربر درخواست میگردد و ضمن مراحل نصب پنجره های متنوع و زیبای
لینوکس مندریک بصورت مصور شما را از قابلیتهای بی نظیر آن مطلع مینماید .


مرحله ورود رمز مدیرسیستم Root Password :


این مرحله از اهمیت بالائی در حفظ امنیت سیستم شما برخوردار است .
شما میتوانید با انتخاب یک کلمه رمز خوب سیستم خودرا از گزند دستکاری غیر مجاز از
راه دور یا نزدیک بیمه کنید یا اینکه در صورت تمایل با انتخاب گزینه no password
سیستم خود را بدون حفاظ امنیتی رها نمائید . البته انتخاب با شماست ؟؟؟


توجه کنید که حداقل طول کلمه عبور شش کاراکتر میباشد و هیچ
محدودیتی در نوع کاراکتر مورد استفاده شما ندارد .


مرحله افزودن یک کاربر Adding a User :


در این مرحله علاوه بر سطح امنیتی کاربر ریشه یک یاچند کاربر با
سطوح دسترسی مختلف میتوانید تعریف کنید ؛ همانطوریکه میدانید لینوکس یک سیستم چند
کاربره است و هر کاربر تعریف شده توسط مدیر سیستم دارای محدودیتها یا اختیارات خاص
میباشد .


ضمنا میتوان برای هر کاربر سیستم یک کاراکتر یا شکلک موجود را
انتخاب کرد و در مرحله بعد همچنین میتوان با انتخاب گزینه automatically log into
the system در دفعات بعدی که سیستم بوت میشود بدون نیاز به ورود کلمه عبور و پسورد
کاربر به محیط گرافیکی وارد شد . این گزینه صرفا برای مصارف خانگی و در محیطهای امن
یا در کامپیوترهای حاوی اطلاعات کم ارزش کاربرد دارد و استفاده از آن اکیدا برای
سیستمهای امن توصیه نمیشود .


مرحله نصب بوت لودر Installing a
Bootloader :


لینوکس مندریک بطور پیش گزیده بوت لودر LILO را برای مدیریت
دوسیستم عامل لینوکس و ویندوز در کنار هم نصب میکند . کاربر میتواند انتخاب کند که
بوت لودر برروی first sector of boot drive یا MBR یا first sector of root
partition یا روی فلاپی ذخیره کند .


نکته : ذخیره بوت لودر بر روی فلاپی درایو باعث میشود که برای بوت
کردن سیستم به لینوکس هر بار شما نیاز به فلاپی مربوطه داشته باشید .


مرحله انتخاب گزینه
های اختیاری Check Miscellaneous Parameters :


در این مرحله تنظیمات اعمال شده سیستم اعم از سخت افزار و نرم
افزار و امنیت و ... نمایش یافته و به کاربر اجازه پیکربندی مستقل هر یک داده میشود
. به یاد داشته باشید که تنظیماتی مثل Time Zone Options و پیکربندی سخت افزارها
غیره در این مرحله و بعد از پایان نصب قابل انجامند ولی انجام این تنظیمات برای
کاربران تازه کار در این مرحله ساده تر است .


مرحله به روز رسانی سیستم Installing
Updates from the Internet :


اگر شما سی دیهای اوریژینال لینوکس مندریک را در اختیار داشته
باشید یا در mandrake club با پرداخت هزینه اندکی عضو شده باشید میتوانید در این
مرحله به چند کلیک و به شرط متصل بودن به اینترنت سیستم خود را به روز نمائید .
اینکار مسلما امنیت سیستم را تضمین میکند ولی نیازمند پرداخت هزینه میباشد . البته
به روز رستنی سیستم بصورت دستی و از طریق داونلود مستقیم فایلهای rpm به روز رسانی
شده از سایت mandrakesecure.com قابل انجام است ولی اینکار نیازمند تسلط کامل بر
سیستم لینوکس بصورت یک کاربر حرفه ای است و مسلما شما هم حتی اگر اکنون حرفه ای
نباشید حتما روزی به این درجه از معلومات خواهید رسید که آنرا مثل آب خوردن انجام
دهید !


نکته : مطمئن باشید که لینوکس در همین شکل خود هم یعنی قبل از
update شدن هزاران بار امن تر از ویندوز است !!!!!!


خاتمه کار It's Finished!


در این مرحله سیستم
دوباره راه اندازی شده و اینبار در ابتدای عملیات BOOT منوی زیبای بوت لودر LILO با
نمای آبی رنگ برای انتخاب نوع سیستم عامل روبروی شما قرار میگیرد .
این منو بصورت پیش گزیده روی گزینه linux قرار دارد و شما هم
اگر مدتی با این سیستم عامل کار کنید دیگر حتی فکر بوت کردن کامپیوتر با ویندوز را
نخواهید کرد .


تفاوت میزبانی ویندوز و لینوکس

در زمينه ميزبانی وب همواره 2 سيستم عامل مهم وجود داشته است: ويندوز و يونيکس (لينوکس). مهمترين سوالی که همواره در اين زمينه از ما ميشود آن است که کدام سيستم برای سايت ما مناسب است؟ ويندوز يا لينوکس؟ پاسخ ما با توجه به هدف شما از داشتن وب سايت و برنامه ای که برای آن سايت در نظر داريد متفاوت است. ما اکثرا به دانش آموختگان خود توصيه ميکنيم که برای شروع با لينوکس شروع کنند و اگر در آينده نياز به گسترش کار و استفاده از قابليتهای ويندوز بود، سايت خود را به ويندوز منتقل نمايند.

معمولا سرورهای ويندوز قابليتهای بيشتری دارند و البته از نظر هزينه گرانتر از لينوکس ميباشند. اما سرورهای لينوکس معمولا با ثبات تر (Stable) هستند و از نظر سرعت نيز بين دو سيستم تفاوت چندانی وجود ندارد.

از نظر امنيت سرورهای لينوکس امن تر از ويندوز هستند. اما در شرکت ارتباط نوين با در نظر گرفتن تمامي مسائل امنيتی بر روی هر دو سيستم امنيت هر دو پلاتفرم را تضمين مينماييم و به شما پيشنهاد ميکنيم در هنگام انتخاب سرور بيشتر به امکاناتی که به شما ارائه ميشوند توجه کنيد تا مسائل امنيتی.

نکته مهم : عده ای تصور ميکنند که برای استفاده از سرور لينوکس ، بايد بر روی کامپيوتر خود سيستم عامل لينوکس نصب کنند. اين فرضيه 100% اشتباه است و کاربران با هر سيستم عاملی ميتوانند به سادگی از خدمات سرورهای لينوکس و سايتهايی که بر روی اين سيستم عامل قرار دارند استفاده نمايند. در کاربری خدمات اين سرورها هيچ مشکلی وجود ندارد و بعضا حتی از کار با ويندوز نيز راحتتر است.

جدول مقايسه قابليتها و تواناييهای دو سيستم عامل (بدترين=0 ، بهترين=5) :

ويندوز 2003 لينوکس  
4 5 قابليت اطمينان
4 5 سادگی استفاده
5 5 قابليت ارتقاء در صورت نياز
5 3 قابليت کار با محصولات مايکروسافت
3 5

نرم افزارهای رايگان يا Open Source

5 5 سرعت
5 5 امکانات
5 5 قيمت

نرم افزارهايي که توسط اين سيستمها پشتيبانی ميشوند :

 

  لينوکس ويندوز 2003
Flash
Shockwave
Real Audio/Video
CGI-Scripts
Perl
PHP
SSH
MySQL
Web-Based Control Panel
Anonymous FTP
Web Site Statistics
Web-Based Email
SQL 2000
Cold Fusion
ASP
MS Access
Visual Basic Scripts
Windows Media

.NET Framework 1 & 2